rcmdnk's blog

Amazon.co.jp: Deprecated E: Boris S.: デジタルミュージック

Vimを立ち上げた所[dein] vim-scripts.org is deprecated. と言ったメッセージが出ていました。

Sponsored Links

[dein] kim-scripts.org is deprecated.

Dein.vim は言わずと知れたVimのプラグインマネージャーです。

Dein.vimの先日のアップデートで

$ vim
[dein] vim-scripts.org is deprecated. You can use "vim-scripts/applescript.vim" instead.
[dein] vim-scripts.org is deprecated. You can use "vim-scripts/applescript.vim" instead.
[dein] vim-scripts.org is deprecated. You can use "vim-scripts/vcscommand.vim" instead.
[dein] vim-scripts.org is deprecated. You can use "vim-scripts/vcscommand.vim" instead.
[dein] vim-scripts.org is deprecated. You can use "vim-scripts/dbext.vim" instead.
[dein] vim-scripts.org is deprecated. You can use "vim-scripts/dbext.vim" instead.
[dein] Not installed plugins: ['applescript.vim', 'dbext.vim', 'vcscommand.vim']
[dein] Update started: (2017/05/04 XX:XX:XX)
[dein] Done: (2017/05/04 XX:XX:XX)
Press ENTER or type command to continue

みたいなメッセージが起動時に出るようになりました。

これは、今までは vim-scripts所有の レポジトリに関してはユーザー名を入れなくても 自動でvim-scripts/を補完してくれていたのを辞める様にしたからみたいです。

なので、.vimrcの中で、

call dein#add('vcscommand.vim')

となってるところを、

call dein#add('vim-scripts/vcscommand.vim')

としてあげればこのメッセージは出なくなり、正しくロードされる様になります。

元々vim-scriptsのものとしてインストールされているので、 .vimrcを書き直すだけで新規にcheckoutしてくることもなくそのまま使える状態です。

Sponsored Links
Sponsored Links

« Homebrew 1.2.0リリース Homebrewで多くインストールされているパッケージ »